PS3Xploit

Custom Firmware Installer

Compatible models: PS3 25XX Models & Lower  (If minimum firmware version is 3.60)
Requirements: Firmware 4.84 OFW

PS3HEN

All PlayStation 3 models run homebrew

Compatible models: PS3 (Late) 25xx 3xxx and 4xxxModels (Slim + SuperSlim – Minimum Firmware Version is not important)
Requirements: Firmware 4.84 HFW

Full DEX Conversion

Install official DEX firmware

Recommended models: PS3 25XX Models & Lower  (If minimum firmware version is 3.60)
WARNING: This is tricky! Read warning first!

Skip to toolbar